How to Installing mcrypt php extension?

For Plesk 7.5 Reloaded with PHP version 5.0 :
Download php-mcrypt package
# wget http://3es.atomicrocketturtle.com/atomic-testing/art/4ES/RPMS/php-mcrypt-5.0.4-14.rhel4.art.i386.rpm
Install php-mcrypt package
# rpm -i php-mcrypt-5.0.4-14.rhel4.art.i386.rpm --nodeps

Note : –nodeps needed to avoid ‘failed dependencies’ warning

For Plesk 7.5 Reloaded without PHP version 5.0 (still in original version) :
# wget http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt

# rpm --import RPM-GPG-KEY.dag.txt

# wget http://dag.wieers.com/rpm/packages/libmcrypt/libmcrypt-devel-2.5.7-1.2.el4.rf.i386.rpm

# rpm -i libmcrypt-devel-2.5.7-1.2.el4.rf.i386.rpm

# wget http://dag.wieers.com/rpm/packages/libmcrypt/libmcrypt-2.5.7-1.2.el4.rf.i386.rpm

# rpm -i libmcrypt-2.5.7-1.2.el4.rf.i386.rpm

# wget http://dag.wieers.com/rpm/packages/libmhash/libmhash-0.9.1-1.2.el4.rf.i386.rpm

# rpm -i libmhash-0.9.1-1.2.el4.rf.i386.rpm

# wget http://dag.wieers.com/rpm/packages/libmhash/libmhash-devel-0.9.1-1.2.el4.rf.i386.rpm

# rpm -i libmhash-devel-0.9.1-1.2.el4.rf.i386.rpm

# wget http://prdownloads.sourceforge.net/phprpms/php-mhash-4.3.9-3.2.1.i386.rpm?download

# rpm -i php-mhash-4.3.9-3.2.1.i386.rpm

# http://prdownloads.sourceforge.net/phprpms/php-mcrypt-4.3.9-3.2.1.i386.rpm?download

# rpm -i php-mcrypt-4.3.9-3.2.1.i386.rpm

This installation produced “/etc/php.d/mcrypt.ini” as an additional .ini files which contains extension=mcrypt.so. mcrypt.so?is?in /usr/lib/php4 directory. You should copy mcrypt.so to /usr/lib/php/modules (# cp mcrypt.so /usr/lib/php/modules)

Add Comment