Safemode Errors when upgrading

If you trying to use the auto-upgrade feature of WordPress and on the page where it asks for my FTP details, It has at the top of the page :

Warning: touch() [function.touch]: SAFE MODE Restriction in effect. The script whose uid is 13089 is not allowed to access /tmp owned by uid 0 in /www/oxyhost.com/j/o/o/joober1212/htdocs/wp-admin/includes/file.php on line 174

Warning: fileowner() [function.fileowner]: SAFE MODE Restriction in effect. The script whose uid is 13089 is not allowed to access /tmp owned by uid 0 in /www/oxyhost.com/j/o/o/joober1212/htdocs/wp-admin/includes/file.php on line 628

Warning: fileowner() [function.fileowner]: stat failed for /tmp/1234307611 in /www/oxyhost.com/j/o/o/joober1212/htdocs/wp-admin/includes/file.php on line 628

Warning: unlink() [function.unlink]: SAFE MODE Restriction in effect. The script whose uid is 13089 is not allowed to access /tmp owned by uid 0 in /www/oxyhost.com/j/o/o/joober1212/htdocs/wp-admin/includes/file.php on line 630

First of all, the UID is known as the Unique IDentifier. What that is your ‘membership’ number on the server. Yours is 13089, mine will be something else, Nayan’s will be something else, etc.

UID 0 is root. The ‘god’ of the machine. So ‘god’ owns the folder known as /tmp and because of that you are denied access to it. So it’s telling you that you cannot use /tmp.

The best solution for that: I just upgrade manually .

1. download the WordPress 2.7.1 archive.

2. extract to the specified folder.

3. Just copied all modified files to specified folder.

Add Comment